🪲 Neopixel leuchtet im Modus Webradio bei WDR2 nicht

@compactflash hat mir per Mail einen, wie ich finde, kuriosen Bug mitgeteilt. Und zwar leuchtet der Neopixel nicht im Modus Webradio - allerdings nur bei WDR2.
Also habe ich mal versucht das Ganze nachzustellen - ist ja ziemlich trivial. Habe dazu eine neue Karte angelernt und sie aufgelegt.

RFID-Karte erkannt: (ISO-14443) ID: b0-d6-09-32
RFID-Karte empfangen: 176214009050
RFID-Karte ist im NVS nicht hinterlegt.
RSSI: -40 dBm
RFID-Karte erkannt: (ISO-14443) ID: b0-d6-09-32
RFID-Karte empfangen: 176214009050
Modus: Webstream
Neue Playlist empfangen mit 1 Titel(n)
info : Connect to new host: „http://www.wdr.de/wdrlive/media/wdr2.m3u
info : PSRAM found, inputBufferSize: 283615 bytes
no cover image for webstream
info : buffers freed, free Heap: 100228 bytes
info : Connection has been established in 123 ms, free Heap: 106480 bytes
www.wdr.de/wdrlive/media/wdr2.m3u‘ wird abgespielt (1 von 1)
info : Connect to new host: „http://wdr-wdr2-rheinland.icecast.wdr.de/wdr/wdr2/rheinland/mp3/128/stream.mp3?ar-distributor=ffa1
info : buffers freed, free Heap: 106376 bytes
info : Connection has been established in 48 ms, free Heap: 105932 bytes
info : redirect to new host "http://d141.rndfnk.com/ard/wdr/wdr2/rheinland/mp3/128/stream.mp3?aggregator=app&cid=01FBS03TJ7KW307WSY5W0W4NYB&sid=2EqL26O65yHX8Odp70XjHE3gh63&token=zqKXAJyYw2XR-s
info : Connect to new host: "http://d141.rndfnk.com/ard/wdr/wdr2/rheinland/mp3/128/stream.mp3?aggregator=app&cid=01FBS03TJ7KW307WSY5W0W4NYB&sid=2EqL26O65yHX8Odp70XjHE3gh63&token=zqKXAJyYw2XR-s
info : buffers freed, free Heap: 105736 bytes
info : Connection has been established in 35 ms, free Heap: 105300 bytes
bitrate : 128000
info : icy-name: WDR 2 Rheinland aktuell, Westdeutscher Rundfunk Koeln
station : WDR 2 Rheinland aktuell, Westdeutscher Rundfunk Koeln
icyurl : WDR 2 - Radio - WDR
info : MP3Decoder has been initialized, free Heap: 74544 bytes
lasthost : http://d141.rndfnk.com/ard/wdr/wdr2/rheinland/mp3/128/stream.mp3?aggregator=app&cid=01FBS03TJ7KW307WSY5W0W4NYB&sid=2EqL26O65yHX8Odp70XjHE3gh63&token=zqKXAJyYw2XR-sYl7VWfyjQO-4_d10M9jfao
info : stream ready
info : syncword found at pos 0
info : MP3 decode error -2 : MAINDATA_UNDERFLOW
info : syncword found at pos 0
info : MP3 decode error -2 : MAINDATA_UNDERFLOW
info : syncword found at pos 0
info : Channels: 2
info : SampleRate: 48000
info : BitsPerSample: 16
info : BitRate: 128000
info : StreamTitle=‚Wir sind der Westen‘
streamtitle : Wir sind der Westen

Sieht erstmal alles ok aus.
Aber tatsächlich: Die beiden LEDs auf dem Neopixel leuchten nicht. Ich lege eine andere Karte auf: leuchtet wieder. Ich lege wieder die WDR-Karte auf: LEDs wieder aus :rofl:.
Ad hoc fällt mir dazu nix ein. Vielleicht gibt es irgendwo eine Race Condition!? :thinking:.

Auch der Stream für OWL? oder der für iOS?

Hi , ich habe andere Streams noch nicht getestet , ich glaube aber das sich einiges geändert hat weil bei mir unter Apple-Musik auch einige Streams nicht mehr laufen. Es betrifft aber auch andere Sender der ARD. Das muss ich mal erforschen.
Der Stream wird ja gespielt , halt leuchtet der Neopixel nicht .
Das ist aber nicht das Problem. Das Kuriosum trat erst auf als ich wegen anderer Probleme (z.Bsp. booten von falscher Partition) 3 ESP32-Boards mittels Erase gelöscht habe . Dann WDR2 neu zugeordnet und dann trat der Fehler auf. Definitiv hat es bis dahin funktioniert und den neu eingetragenen Link habe ich aus einer Backup-Datei aus Dezember 2021 kopiert. Der Stream funktioniert auch wenn man die Karte statt im Modus Webradio im Modus Liste zuordnet.

Hi @biologist

Der Fehler bei Single-LED , welchen ich dir vor einiger Zeit geschildert habe , hat anscheinend auch mit WDR2 zu tun . Kannste vergessen .

VG