Probleme mit RC522

Hallo zusammen,

ich habe endlich das Bord mit den Komponenten verkabelt und eigentlich auch schon erfolgreich die Firmware übertragen.
Die diode D1 am RFID-RC522 ist auch schon fleißig am Blinken, jedoch werden keine Karten erkannt. Die ganzen Settings habe ich auch alle so wie in der Anleitung übernommen.

Hat jemand eine Idee?

Der RFID Empfänger wird als Version 0 erkannt.


| | / | | _ \ _ _ () _ __ ___
| | _ \ | |
) | | | | | | | | ’
\ / _
| |
) | | __/ | || | | | | | | | | () |
|
____| |
/ || _,| || || |_| ___/
Rfid-controlled musicplayer

N [365] Software-revision: 20240125-1
N [365] Git-revision: unknown
N [365] Arduino version: 2.0.14
N [375] ESP-IDF version: 4.4.6
N [375] Wakeup was not caused by deepsleep: 0
N [376] Versuche SD-Karte im SD_MMC-Modus (1 Bit) zu mounten…
D [386] SD card type: SDSC
N [386] SD-Kartengröße / freier Speicherplatz: 59 MB / 54 MB
I [387] FTP-User wurde aus NVS geladen: esp32
I [398] FTP-Passwort wurde aus NVS geladen: esp32
D [459] RC522 firmware version=0
D [509] RFID-Tags koennen jetzt gescannt werden…
I [511] Hostname aus NVS geladen: ESPuino-fepo
N [513] SSID 0 von NVS geladen: Wohnzimmer
N [666] Versuche mit WLAN ‚Wohnzimmer‘ zu verbinden…
D [739] Freier Heap-Speicher nach Setup-Routine: 140608
D [740] PSRAM: 4189035 bytes
D [740] Flash-size: 16777216 bytes
N [1429] Lautsprecher eingeschaltet
I [1430] Maximale Lautstärke wurde gesetzt auf: 21
N [1545] Verbunden mit WLAN ‚Wohnzimmer‘ (Signalstärke: -56 dBm, Kanal: 5, MAC-Adresse: 1C:ED:6F:D2:3E:9C)
N [1545] Aktuelle IP: 192.168.178.58
N [1556] Synchronisiere Uhrzeit via NTP…
N [1569] mDNS gestartet: http://ESPuino-fepo.local
N [1573] HTTP-Server gestartet.
N [5472] Datum/Uhrzeit empfangen von NTP-Server: 28.02.2024, 20:49:36
I [10004] Aktuelle Batteriespannung: 3.39 V
I [10006] Aktuelle Batterieladung: 100.00 %
D [16978] ws[/ws][1] connect
D [60011] RSSI: -56 dBm
I [82568] Aktuelle Batteriespannung: 3.32 V
I [82571] Aktuelle Batterieladung: 100.00 %

Schrauben würde ich da ja keine hinmachen.
Welche Pins hast du wo angeschlossen?

Die schrauben haben Kunststoff U-Scheiben

RC522 ESPUINO

SDA = CS (gelb)
SCK =SCK (blau)
MOSI =MOSI(orange)
MISO =MISO(grün)
IRQ =IRQ(grau)
GND =GND(braun)
RST =RST(weiß)
3,3V =3,3V(rot)

Ist das nicht eine Power-on LED? Ich habe die noch nie blinken gesehen

Ja , die Led blinkt sehr schnell und schwach

Den rc522 hatte ich schon am arduino Nano am Laufen gehabt und er hat auch die Karten gelesen.
Ich kann mich aber nicht erinnern ob die Led geblinkt hat.

imho ist das nur eine Power LED, blinken ist damit „falsch“

OK verstehe,

Ich werde mal heute Abend nochmal die Verkabelung und die Lötstellen kontrollieren.
Sonst muß ich es mit einem anderen Leser rc522 testen, um einen Hardwaredefekt auszuschließen.

Das Mapping sieht auf jeden Fall korrekt aus.
Und ja: Blinken sollte diese LED eigentlich nicht.

Fehler gefunden!

Habe vergessen den Jumper j6 zu setzen, also keine 3,3V Spannungsversorgung am RFID Anschluss.

Mir ist aber aufgefallen, das bei schnellem Wechsel der Karten die Erkennung ncht zuverlässig ausgeführt wird.

Das ist eine Hommage an die 80/90er: Da konnte man auch nicht jede Sekunde ne neue Kassette/CD einlegen :rofl:

6 „Gefällt mir“